CVE-2022-22629

NameCVE-2022-22629
DescriptionA buffer overflow issue was addressed with improved memory handling
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-5115-1, DSA-5116-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
webkit2gtk (PTS)stretch2.18.6-1~deb9u1vulnerable
buster2.34.6-1~deb10u1vulnerable
buster (security)2.36.0-3~deb10u1fixed
bullseye2.34.6-1~deb11u1vulnerable
bullseye (security)2.36.0-3~deb11u1fixed
bookworm2.36.0-3fixed
sid2.36.2-1fixed
wpewebkit (PTS)bullseye2.34.6-1~deb11u1vulnerable
bullseye (security)2.36.0-2~deb11u1fixed
bookworm, sid2.36.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
webkit2gtksourcebuster2.36.0-3~deb10u1DSA-5115-1
webkit2gtksourcebullseye2.36.0-3~deb11u1DSA-5115-1
webkit2gtksource(unstable)2.36.0-1
wpewebkitsourcebullseye2.36.0-2~deb11u1DSA-5116-1
wpewebkitsource(unstable)2.36.0-2

Notes

[stretch] - webkit2gtk <ignored> (Not covered by security support in stretch)
https://webkitgtk.org/security/WSA-2022-0004.html

Search for package or bug name: Reporting problems