CVE-2022-22719

NameCVE-2022-22719
DescriptionA carefully crafted request body can cause a read to a random memory area which could cause the process to crash. This issue affects Apache HTTP Server 2.4.52 and earlier.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-2960-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
apache2 (PTS)buster, buster (security)2.4.38-3+deb10u7vulnerable
bullseye2.4.54-1~deb11u1fixed
bullseye (security)2.4.52-1~deb11u2vulnerable
bookworm, sid2.4.54-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
apache2sourcestretch2.4.25-3+deb9u13DLA-2960-1
apache2sourcebullseye2.4.53-1~deb11u1
apache2source(unstable)2.4.53-1

Notes

[buster] - apache2 <no-dsa> (Minor issue)
https://httpd.apache.org/security/vulnerabilities_24.html#CVE-2022-22719
Fixed by: https://svn.apache.org/r1898694

Search for package or bug name: Reporting problems