CVE-2022-22728

NameCVE-2022-22728
DescriptionA flaw in Apache libapreq2 versions 2.16 and earlier could cause a buffer overflow while processing multipart form uploads. A remote attacker could send a request causing a process crash which could lead to a denial of service attack.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1018191

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libapreq2 (PTS)buster, buster (security)2.13-7~deb10u1vulnerable
bookworm, sid, bullseye2.13-7vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libapreq2source(unstable)(unfixed)1018191

Notes

https://www.openwall.com/lists/oss-security/2022/08/25/3

Search for package or bug name: Reporting problems