CVE-2022-22817

NameCVE-2022-22817
DescriptionPIL.ImageMath.eval in Pillow before 9.0.0 allows evaluation of arbitrary expressions, such as ones that use the Python exec method.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pillow (PTS)stretch4.0.0-4+deb9u1vulnerable
stretch (security)4.0.0-4+deb9u3vulnerable
buster5.4.1-2+deb10u2vulnerable
buster (security)5.4.1-2+deb10u1vulnerable
bullseye8.1.2+dfsg-0.3vulnerable
bookworm8.4.0-1vulnerable
sid9.0.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pillowsource(unstable)9.0.0-1

Notes

https://pillow.readthedocs.io/en/stable/releasenotes/9.0.0.html#restrict-builtins-available-to-imagemath-eval
https://github.com/python-pillow/Pillow/commit/8531b01d6cdf0b70f256f93092caa2a5d91afc11 (9.0.0)

Search for package or bug name: Reporting problems