CVE-2022-22818

NameCVE-2022-22818
DescriptionThe {% debug %} template tag in Django 2.2 before 2.2.27, 3.2 before 3.2.12, and 4.0 before 4.0.2 does not properly encode the current context. This may lead to XSS.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2906-1
Debian Bugs1004752

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python-django (PTS)stretch1:1.10.7-2+deb9u9vulnerable
stretch (security)1:1.10.7-2+deb9u16fixed
buster, buster (security)1:1.11.29-1~deb10u1vulnerable
bullseye2:2.2.26-1~deb11u1vulnerable
bookworm, sid2:3.2.13-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python-djangosourcestretch1:1.10.7-2+deb9u15DLA-2906-1
python-djangosource(unstable)2:3.2.12-11004752

Notes

[bullseye] - python-django <no-dsa> (Minor issue)
[buster] - python-django <no-dsa> (Minor issue)
https://www.djangoproject.com/weblog/2022/feb/01/security-releases/
https://github.com/django/django/commit/394517f07886495efcf79f95c7ee402a9437bd68 (main)
https://github.com/django/django/commit/01422046065d2b51f8f613409cad2c81b39487e5 (4.0.2)
https://github.com/django/django/commit/1a1e8278c46418bde24c86a65443b0674bae65e2 (3.2.12)
https://github.com/django/django/commit/c27a7eb9f40b64990398978152e62b6ff839c2e6 (2.2.27)

Search for package or bug name: Reporting problems