CVE-2022-22827

NameCVE-2022-22827
DescriptionstoreAtts in xmlparse.c in Expat (aka libexpat) before 2.4.3 has an integer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-2904-1, DSA-5073-1
Debian Bugs1003474

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
expat (PTS)buster, buster (security)2.2.6-2+deb10u4fixed
bullseye (security), bullseye2.2.10-2+deb11u3fixed
bookworm, sid2.4.8-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
expatsourcestretch2.2.0-2+deb9u4DLA-2904-1
expatsourcebuster2.2.6-2+deb10u2DSA-5073-1
expatsourcebullseye2.2.10-2+deb11u1DSA-5073-1
expatsource(unstable)2.4.3-11003474

Notes

https://github.com/libexpat/libexpat/pull/539
https://github.com/libexpat/libexpat/commit/9f93e8036e842329863bf20395b8fb8f73834d9e (R_2_4_3)

Search for package or bug name: Reporting problems