CVE-2022-22844

NameCVE-2022-22844
DescriptionLibTIFF 4.3.0 has an out-of-bounds read in _TIFFmemcpy in tif_unix.c in certain situations involving a custom tag and 0x0200 as the second word of the DE field.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tiff (PTS)stretch4.0.8-2+deb9u5vulnerable
stretch (security)4.0.8-2+deb9u7vulnerable
buster4.1.0+git191117-2~deb10u2vulnerable
buster (security)4.1.0+git191117-2~deb10u3vulnerable
bullseye4.2.0-1vulnerable
bookworm, sid4.3.0-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tiffsource(unstable)(unfixed)

Notes

[bullseye] - tiff <no-dsa> (Minor issue)
[buster] - tiff <no-dsa> (Minor issue)
[stretch] - tiff <postponed> (Minor issue; read overflow in CLI utility)
https://gitlab.com/libtiff/libtiff/-/issues/355
https://gitlab.com/libtiff/libtiff/-/merge_requests/287

Search for package or bug name: Reporting problems