CVE-2022-22846

NameCVE-2022-22846
DescriptionThe dnslib package through 0.9.16 for Python does not verify that the ID value in a DNS reply matches an ID value in a query.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python-dnslib (PTS)buster0.9.7+hg20170303-1vulnerable
bullseye0.9.14-1vulnerable
bookworm, sid0.9.19-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python-dnslibsource(unstable)0.9.18-1

Notes

[bullseye] - python-dnslib <no-dsa> (Minor issue)
[buster] - python-dnslib <no-dsa> (Minor issue)
https://github.com/paulc/dnslib/issues/30
https://github.com/paulc/dnslib/commit/76e8677699ed098387d502c57980f58da642aeba

Search for package or bug name: Reporting problems