CVE-2022-2294

NameCVE-2022-2294
DescriptionHeap buffer overflow in WebRTC in Google Chrome prior to 103.0.5060.114 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDSA-5180-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
chromium (PTS)buster, buster (security)90.0.4430.212-1~deb10u1vulnerable
bullseye104.0.5112.79-1~deb11u1fixed
bullseye (security)106.0.5249.91-1~deb11u1fixed
bookworm, sid106.0.5249.91-1fixed
webkit2gtk (PTS)buster2.36.4-1~deb10u1vulnerable
buster (security)2.38.0-1~deb10u1fixed
bullseye2.36.7-1~deb11u1fixed
bullseye (security)2.38.0-1~deb11u1fixed
bookworm, sid2.38.0-3fixed
wpewebkit (PTS)bullseye2.36.7-1~deb11u1fixed
bullseye (security)2.38.0-1~deb11u1fixed
bookworm, sid2.38.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
chromiumsourcestretch(unfixed)end-of-life
chromiumsourcebuster(unfixed)end-of-life
chromiumsourcebullseye103.0.5060.114-1~deb11u1DSA-5180-1
chromiumsource(unstable)103.0.5060.114-1
webkit2gtksourcebuster2.36.6-1~deb10u1
webkit2gtksourcebullseye2.36.6-1~deb11u1
webkit2gtksource(unstable)2.36.6-1unimportant
wpewebkitsourcebullseye2.36.6-1~deb11u1
wpewebkitsource(unstable)2.36.6-1unimportant

Notes

[buster] - chromium <end-of-life> (see DSA 5046)
[stretch] - chromium <end-of-life> (see DSA 4562)
https://www.openwall.com/lists/oss-security/2022/07/28/2
Debian WebKitGTK and WPE WebKit binary packages are built without LibWebRTC
https://googleprojectzero.github.io/0days-in-the-wild//0day-RCAs/2022/CVE-2022-2294.html

Search for package or bug name: Reporting problems