CVE-2022-22950

NameCVE-2022-22950
Descriptionn Spring Framework versions 5.3.0 - 5.3.16 and older unsupported versions, it is possible for a user to provide a specially crafted SpEL expression that may cause a denial of service condition.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libspring-java (PTS)buster4.3.22-4vulnerable
bookworm, sid, bullseye4.3.30-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libspring-javasourcestretch(unfixed)end-of-life
libspring-javasource(unstable)(unfixed)

Notes

[bullseye] - libspring-java <no-dsa> (Minor issue)
[buster] - libspring-java <no-dsa> (Minor issue)
[stretch] - libspring-java <end-of-life> (EOL'd for stretch)
https://tanzu.vmware.com/security/cve-2022-22950

Search for package or bug name: Reporting problems