CVE-2022-22965

NameCVE-2022-22965
DescriptionA Spring MVC or Spring WebFlux application running on JDK 9+ may be vulnerable to remote code execution (RCE) via data binding. The specific exploit requires the application to run on Tomcat as a WAR deployment. If the application is deployed as a Spring Boot executable jar, i.e. the default, it is not vulnerable to the exploit. However, the nature of the vulnerability is more general, and there may be other ways to exploit it.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libspring-java (PTS)stretch4.3.5-1vulnerable
stretch (security)4.3.5-1+deb9u1vulnerable
buster4.3.22-4vulnerable
bookworm, sid, bullseye4.3.30-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libspring-javasourcestretch(unfixed)end-of-life
libspring-javasource(unstable)(unfixed)

Notes

[bullseye] - libspring-java <no-dsa> (No reverse dependencies in the archive affected)
[buster] - libspring-java <no-dsa> (No reverse dependencies in the archive affected)
[stretch] - libspring-java <end-of-life> (EOL'd for stretch)
https://bugalert.org/content/notices/2022-03-30-spring.html
https://tanzu.vmware.com/security/cve-2022-22965

Search for package or bug name: Reporting problems