CVE-2022-22968

NameCVE-2022-22968
DescriptionIn Spring Framework versions 5.3.0 - 5.3.18, 5.2.0 - 5.2.20, and older unsupported versions, the patterns for disallowedFields on a DataBinder are case sensitive which means a field is not effectively protected unless it is listed with both upper and lower case for the first character of the field, including upper and lower case for the first character of all nested fields within the property path.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libspring-java (PTS)stretch4.3.5-1vulnerable
stretch (security)4.3.5-1+deb9u1vulnerable
buster4.3.22-4vulnerable
bookworm, sid, bullseye4.3.30-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libspring-javasourcestretch(unfixed)end-of-life
libspring-javasource(unstable)(unfixed)

Notes

[bullseye] - libspring-java <no-dsa> (Minor issue)
[buster] - libspring-java <no-dsa> (Minor issue)
[stretch] - libspring-java <end-of-life> (EOL'd for stretch)
https://tanzu.vmware.com/security/cve-2022-22968

Search for package or bug name: Reporting problems