CVE-2022-22971

NameCVE-2022-22971
DescriptionIn spring framework versions prior to 5.3.20+ , 5.2.22+ and old unsupported versions, application with a STOMP over WebSocket endpoint is vulnerable to a denial of service attack by an authenticated user.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libspring-java (PTS)buster4.3.22-4vulnerable
bookworm, bullseye, sid4.3.30-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libspring-javasourcestretch(unfixed)end-of-life
libspring-javasourcebuster(unfixed)end-of-life
libspring-javasource(unstable)(unfixed)

Notes

[buster] - libspring-java <end-of-life> (No longer supported in LTS)
[stretch] - libspring-java <end-of-life> (No longer supported in LTS)
https://tanzu.vmware.com/security/cve-2022-22971

Search for package or bug name: Reporting problems