CVE-2022-23218

NameCVE-2022-23218
DescriptionThe deprecated compatibility function svcunix_create in the sunrpc module of the GNU C Library (aka glibc) through 2.34 copies its path argument on the stack without validating its length, which may result in a buffer overflow, potentially resulting in a denial of service or (if an application is not built with a stack protector enabled) arbitrary code execution.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3152-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
glibc (PTS)buster2.28-10+deb10u1vulnerable
buster (security)2.28-10+deb10u2fixed
bullseye2.31-13+deb11u4fixed
bookworm2.36-5fixed
sid2.36-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
glibcsourcebuster2.28-10+deb10u2DLA-3152-1
glibcsourcebullseye2.31-13+deb11u3
glibcsource(unstable)2.33-3

Notes

https://sourceware.org/bugzilla/show_bug.cgi?id=28768

Search for package or bug name: Reporting problems