CVE-2022-23220

NameCVE-2022-23220
DescriptionUSBView 2.1 before 2.2 allows some local users (e.g., ones logged in via SSH) to execute arbitrary code as root because certain Polkit settings (e.g., allow_any=yes) for pkexec disable the authentication requirement. Code execution can, for example, use the --gtk-module option. This affects Ubuntu, Debian, and Gentoo.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-5052-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
usbview (PTS)stretch2.0-3fixed
buster, buster (security)2.0-21-g6fe2f4f-2+deb10u1fixed
bullseye (security), bullseye2.0-21-g6fe2f4f-2+deb11u1fixed
bookworm, sid3.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
usbviewsourcestretch(not affected)
usbviewsourcebuster2.0-21-g6fe2f4f-2+deb10u1DSA-5052-1
usbviewsourcebullseye2.0-21-g6fe2f4f-2+deb11u1DSA-5052-1
usbviewsource(unstable)2.0-21-g6fe2f4f-2.1

Notes

[stretch] - usbview <not-affected> (Vulnerable code introduced later)
https://www.openwall.com/lists/oss-security/2022/01/21/1
Introduced by: https://github.com/gregkh/usbview/commit/ddefeba3f67d6a6f394eb57352254c1c8a312671 (v2.1)
Fixed by: https://github.com/gregkh/usbview/commit/bf374fa4e5b9a756789dfd88efa93806a395463b (v2.2)
Hardening: https://github.com/gregkh/usbview/commit/1282782301570b3ee27f82f4f34c2c1a82bfd91a (v2.2)

Search for package or bug name: Reporting problems