CVE-2022-23308

NameCVE-2022-23308
Descriptionvalid.c in libxml2 before 2.9.13 has a use-after-free of ID and IDREF attributes.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-2972-1
Debian Bugs1006489

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libxml2 (PTS)buster2.9.4+dfsg1-7+deb10u3fixed
buster (security)2.9.4+dfsg1-7+deb10u4fixed
bullseye (security), bullseye2.9.10+dfsg-6.7+deb11u2fixed
bookworm, sid2.9.14+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libxml2sourcestretch2.9.4+dfsg1-2.2+deb9u6DLA-2972-1
libxml2sourcebuster2.9.4+dfsg1-7+deb10u3
libxml2sourcebullseye2.9.10+dfsg-6.7+deb11u1
libxml2source(unstable)2.9.13+dfsg-11006489

Notes

https://gitlab.gnome.org/GNOME/libxml2/-/issues/327
https://gitlab.gnome.org/GNOME/libxml2/-/commit/652dd12a858989b14eed4e84e453059cd3ba340e (v2.9.13)

Search for package or bug name: Reporting problems