CVE-2022-23484

NameCVE-2022-23484
Descriptionxrdp is an open source project which provides a graphical login to remote machines using Microsoft Remote Desktop Protocol (RDP). xrdp < v0.9.21 contain a Integer Overflow in xrdp_mm_process_rail_update_window_text() function. There are no known workarounds for this issue. Users are advised to upgrade.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3370-1, DSA-5502-1
Debian Bugs1025879

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xrdp (PTS)bullseye (security), bullseye0.9.21.1-1~deb11u1fixed
bookworm0.9.21.1-1fixed
sid, trixie0.9.24-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xrdpsourcebuster0.9.9-1+deb10u2DLA-3370-1
xrdpsourcebullseye0.9.21.1-1~deb11u1DSA-5502-1
xrdpsource(unstable)0.9.21.1-11025879

Notes

https://github.com/neutrinolabs/xrdp/security/advisories/GHSA-rqfx-5fv8-q9c6
https://github.com/neutrinolabs/xrdp/commit/c2c6efb1d377be6baaa4acbc9d3700490fe92887

Search for package or bug name: Reporting problems