CVE-2022-23515

NameCVE-2022-23515
DescriptionLoofah is a general library for manipulating and transforming HTML/XML documents and fragments, built on top of Nokogiri. Loofah >= 2.1.0, < 2.19.1 is vulnerable to cross-site scripting via the image/svg+xml media type in data URIs. This issue is patched in version 2.19.1.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1026083

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby-loofah (PTS)buster, buster (security)2.2.3-1+deb10u1vulnerable
bullseye2.7.0+dfsg-1vulnerable
bookworm, sid2.19.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ruby-loofahsource(unstable)2.19.1-11026083

Notes

https://github.com/flavorjones/loofah/security/advisories/GHSA-228g-948r-83gx

Search for package or bug name: Reporting problems