CVE-2022-23613

NameCVE-2022-23613
Descriptionxrdp is an open source remote desktop protocol (RDP) server. In affected versions an integer underflow leading to a heap overflow in the sesman server allows any unauthenticated attacker which is able to locally access a sesman server to execute code as root. This vulnerability has been patched in version 0.9.18.1 and above. Users are advised to upgrade. There are no known workarounds.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs1005304

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xrdp (PTS)stretch0.9.1-9+deb9u3fixed
stretch (security)0.9.1-9+deb9u4fixed
buster, buster (security)0.9.9-1+deb10u1fixed
bullseye0.9.12-1.1fixed
sid0.9.19-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xrdpsourcestretch(not affected)
xrdpsourcebuster(not affected)
xrdpsourcebullseye(not affected)
xrdpsource(unstable)0.9.17-2.11005304

Notes

[bullseye] - xrdp <not-affected> (Vulnerable code not present)
[buster] - xrdp <not-affected> (Vulnerable code not present)
[stretch] - xrdp <not-affected> (Vulnerable code not present)
https://github.com/neutrinolabs/xrdp/security/advisories/GHSA-8h98-h426-xf32
Introduced by: https://github.com/neutrinolabs/xrdp/commit/738e346f810c97d578df9e99a36520616ee201be (v0.9.17)
Fixed by: https://github.com/neutrinolabs/xrdp/commit/4def30ab8ea445cdc06832a44c3ec40a506a0ffa

Search for package or bug name: Reporting problems