CVE-2022-23634

NameCVE-2022-23634
DescriptionPuma is a Ruby/Rack web server built for parallelism. Prior to `puma` version `5.6.2`, `puma` may not always call `close` on the response body. Rails, prior to version `7.0.2.2`, depended on the response body being closed in order for its `CurrentAttributes` implementation to work correctly. The combination of these two behaviors (Puma not closing the body + Rails' Executor implementation) causes information leakage. This problem is fixed in Puma versions 5.6.2 and 4.3.11. This problem is fixed in Rails versions 7.02.2, 6.1.4.6, 6.0.4.6, and 5.2.6.2. Upgrading to a patched Rails _or_ Puma version fixes the vulnerability.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs1005391

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
puma (PTS)stretch3.6.0-1vulnerable
stretch (security)3.6.0-1+deb9u1vulnerable
buster3.12.0-2+deb10u2vulnerable
bullseye4.3.8-1vulnerable
bookworm5.5.2-2vulnerable
sid5.6.4-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pumasource(unstable)(unfixed)1005391

Notes

https://github.com/puma/puma/security/advisories/GHSA-rmj8-8hhh-gv5h
https://github.com/puma/puma/commit/b70f451fe8abc0cff192c065d549778452e155bb
Related issue to CVE-2022-23633 for src:rails

Search for package or bug name: Reporting problems