CVE-2022-23647

NameCVE-2022-23647
DescriptionPrism is a syntax highlighting library. Starting with version 1.14.0 and prior to version 1.27.0, Prism's command line plugin can be used by attackers to achieve a cross-site scripting attack. The command line plugin did not properly escape its output, leading to the input text being inserted into the DOM as HTML code. Server-side usage of Prism is not impacted. Websites that do not use the Command Line plugin are also not impacted. This bug has been fixed in v1.27.0. As a workaround, do not use the command line plugin on untrusted inputs, or sanitize all code blocks (remove all HTML code text) from all code blocks that use the command line plugin.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-prismjs (PTS)bullseye1.23.0+dfsg-1+deb11u2fixed
bookworm, sid1.27.0+dfsg+~1.26.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-prismjssourcebullseye1.23.0+dfsg-1+deb11u2
node-prismjssource(unstable)1.27.0+dfsg+~1.26.0-1

Notes

https://github.com/PrismJS/prism/security/advisories/GHSA-3949-f494-cm99
https://github.com/PrismJS/prism/issues/3340
https://github.com/PrismJS/prism/pull/3341
https://github.com/PrismJS/prism/commit/e002e78c343154e1c0ddf9d6a0bb85689e1a5c7c (v1.27.0)

Search for package or bug name: Reporting problems