CVE-2022-23943

NameCVE-2022-23943
DescriptionOut-of-bounds Write vulnerability in mod_sed of Apache HTTP Server allows an attacker to overwrite heap memory with possibly attacker provided data. This issue affects Apache HTTP Server 2.4 version 2.4.52 and prior versions.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-2960-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
apache2 (PTS)buster2.4.38-3+deb10u8fixed
buster (security)2.4.38-3+deb10u10fixed
bullseye2.4.56-1~deb11u2fixed
bullseye (security)2.4.56-1~deb11u1fixed
bookworm2.4.57-2fixed
trixie2.4.58-1fixed
sid2.4.59-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
apache2sourcestretch2.4.25-3+deb9u13DLA-2960-1
apache2sourcebuster2.4.38-3+deb10u8
apache2sourcebullseye2.4.53-1~deb11u1
apache2source(unstable)2.4.53-1

Notes

https://httpd.apache.org/security/vulnerabilities_24.html#CVE-2022-23943
Fixed by: https://svn.apache.org/r1898695
Fixed by: https://svn.apache.org/r1898772

Search for package or bug name: Reporting problems