CVE-2022-23990

NameCVE-2022-23990
DescriptionExpat (aka libexpat) before 2.4.4 has an integer overflow in the doProlog function.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-2904-1, DSA-5073-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
expat (PTS)bullseye (security), bullseye2.2.10-2+deb11u5fixed
bookworm2.5.0-1fixed
sid, trixie2.6.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
expatsourcestretch2.2.0-2+deb9u4DLA-2904-1
expatsourcebuster2.2.6-2+deb10u2DSA-5073-1
expatsourcebullseye2.2.10-2+deb11u1DSA-5073-1
expatsource(unstable)2.4.3-3

Notes

https://github.com/libexpat/libexpat/pull/551
Introduced with: https://github.com/libexpat/libexpat/commit/cb8a4c756d057b948c1b41e7185dd69ef3ade3fb (R_1_95_4)
Fixed by: https://github.com/libexpat/libexpat/commit/ede41d1e186ed2aba88a06e84cac839b770af3a1 (R_2_4_4)

Search for package or bug name: Reporting problems