CVE-2022-24300

NameCVE-2022-24300
DescriptionMinetest before 5.4.0 allows attackers to add or modify arbitrary meta fields of the same item stack as saved user input, aka ItemStack meta injection.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDSA-5075-1
Debian Bugs1004223

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
minetest (PTS)buster, buster (security)0.4.17.1+repack-1+deb10u1fixed
bullseye (security), bullseye5.3.0+repack-2.1+deb11u1fixed
bookworm, sid5.6.1+dfsg+~1.9.0mt8+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
minetestsourcestretch(unfixed)end-of-life
minetestsourcebuster0.4.17.1+repack-1+deb10u1DSA-5075-1
minetestsourcebullseye5.3.0+repack-2.1+deb11u1DSA-5075-1
minetestsource(unstable)5.4.1+repack-11004223

Notes

[stretch] - minetest <end-of-life> (games are not supported in LTS)
https://github.com/minetest/minetest/security/advisories/GHSA-hwj2-xf72-r4cf
Fixed by: https://github.com/minetest/minetest/commit/b5956bde259faa240a81060ff4e598e25ad52dae (5.4.0)
When fixing this issue the fix for GHSA-7q63-4fq2-hqcr should be included,
which is not a vulnerability by itself, and won't get a CVE assigned:
https://github.com/minetest/minetest/security/advisories/GHSA-7q63-4fq2-hqcr
https://github.com/minetest/minetest/commit/8d6a0b917ce1e7f4f1017835af0ca76e79c98c38 (5.2.0)

Search for package or bug name: Reporting problems