CVE-2022-24301

NameCVE-2022-24301
DescriptionIn Minetest before 5.4.0, players can add or subtract items from a different player's inventory.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDSA-5075-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
minetest (PTS)buster, buster (security)0.4.17.1+repack-1+deb10u1fixed
bullseye (security), bullseye5.3.0+repack-2.1+deb11u1fixed
bookworm, sid5.6.1+dfsg+~1.9.0mt8+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
minetestsourcestretch(unfixed)end-of-life
minetestsourcebuster0.4.17.1+repack-1+deb10u1DSA-5075-1
minetestsourcebullseye5.3.0+repack-2.1+deb11u1DSA-5075-1
minetestsource(unstable)5.4.1+repack-1

Notes

[stretch] - minetest <end-of-life> (games are not supported in LTS)
https://github.com/minetest/minetest/security/advisories/GHSA-fvwv-qcq6-wmp5
Fixed by: https://github.com/minetest/minetest/commit/3693b6871eba268ecc79b3f52d00d3cefe761131 (5.4.0)

Search for package or bug name: Reporting problems