CVE-2022-24329

NameCVE-2022-24329
DescriptionIn JetBrains Kotlin before 1.6.0, it was not possible to lock dependencies for Multiplatform Gradle Projects.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1007243

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
kotlin (PTS)sid1.3.31+~1.0.1+~0.11.12-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
kotlinsource(unstable)(unfixed)1007243

Notes

https://blog.jetbrains.com/blog/2022/02/08/jetbrains-security-bulletin-q4-2021/
https://youtrack.jetbrains.com/issue/KT-49449 (not public)

Search for package or bug name: Reporting problems