CVE-2022-24599

NameCVE-2022-24599
DescriptionIn autofile Audio File Library 0.3.6, there exists one memory leak vulnerability in printfileinfo, in printinfo.c, which allows an attacker to leak sensitive information via a crafted file. The printfileinfo function calls the copyrightstring function to get data, however, it dosn't use zero bytes to truncate the data.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1008017

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
audiofile (PTS)bookworm, sid, buster, bullseye0.3.6-5vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
audiofilesource(unstable)(unfixed)1008017

Notes

[bullseye] - audiofile <no-dsa> (Minor issue)
[buster] - audiofile <no-dsa> (Minor issue)
[stretch] - audiofile <no-dsa> (Minor issue)
https://github.com/mpruett/audiofile/issues/60

Search for package or bug name: Reporting problems