CVE-2022-24728

NameCVE-2022-24728
DescriptionCKEditor4 is an open source what-you-see-is-what-you-get HTML editor. A vulnerability has been discovered in the core HTML processing module and may affect all plugins used by CKEditor 4 prior to version 4.18.0. The vulnerability allows someone to inject malformed HTML bypassing content sanitization, which could result in executing JavaScript code. This problem has been patched in version 4.18.0. There are currently no known workarounds.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1015217

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ckeditor (PTS)buster4.11.1+dfsg-1vulnerable
bullseye4.16.0+dfsg-2vulnerable
bookworm, sid4.19.1+dfsg-1fixed
ckeditor3 (PTS)buster3.6.6.1+dfsg-3vulnerable
bookworm, sid, bullseye3.6.6.1+dfsg-7vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ckeditorsource(unstable)4.19.0+dfsg-1
ckeditor3sourcestretch(unfixed)end-of-life
ckeditor3sourcebuster(unfixed)end-of-life
ckeditor3source(unstable)(unfixed)1015217

Notes

[bullseye] - ckeditor <no-dsa> (Minor issue)
[buster] - ckeditor <no-dsa> (Minor issue)
[bullseye] - ckeditor3 <no-dsa> (Minor issue)
[buster] - ckeditor3 <end-of-life> (No longer supported in LTS)
[stretch] - ckeditor3 <end-of-life> (EOL'd for stretch)
https://github.com/ckeditor/ckeditor4/security/advisories/GHSA-4fc4-4p5g-6w89
https://github.com/ckeditor/ckeditor4/commit/d158413449692d920a778503502dcb22881bc949 (4.18.0)
MITRE's referenced patch (above) does not seem related

Search for package or bug name: Reporting problems