CVE-2022-24729

NameCVE-2022-24729
DescriptionCKEditor4 is an open source what-you-see-is-what-you-get HTML editor. CKEditor4 prior to version 4.18.0 contains a vulnerability in the `dialog` plugin. The vulnerability allows abuse of a dialog input validator regular expression, which can cause a significant performance drop resulting in a browser tab freeze. A patch is available in version 4.18.0. There are currently no known workarounds.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1015217

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ckeditor (PTS)buster4.11.1+dfsg-1vulnerable
bullseye4.16.0+dfsg-2vulnerable
bookworm, sid4.19.1+dfsg-1fixed
ckeditor3 (PTS)buster3.6.6.1+dfsg-3vulnerable
bookworm, sid, bullseye3.6.6.1+dfsg-7vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ckeditorsource(unstable)4.19.0+dfsg-1
ckeditor3sourcestretch(unfixed)end-of-life
ckeditor3sourcebuster(unfixed)end-of-life
ckeditor3source(unstable)(unfixed)1015217

Notes

[bullseye] - ckeditor <no-dsa> (Minor issue)
[bullseye] - ckeditor3 <no-dsa> (Minor issue)
[buster] - ckeditor3 <end-of-life> (No longer supported in LTS)
[stretch] - ckeditor3 <end-of-life> (EOL'd for stretch)
https://github.com/ckeditor/ckeditor4/security/advisories/GHSA-f6rf-9m92-x2hh

Search for package or bug name: Reporting problems