CVE-2022-24775

NameCVE-2022-24775
Descriptionguzzlehttp/psr7 is a PSR-7 HTTP message library. Versions prior to 1.8 ...
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs1008236

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php-guzzlehttp-psr7 (PTS)buster1.4.2-0.1vulnerable
bullseye1.7.0-1vulnerable
bookworm, sid1.8.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php-guzzlehttp-psr7source(unstable)1.8.5-11008236

Notes

[bullseye] - php-guzzlehttp-psr7 <no-dsa> (Minor issue)
[buster] - php-guzzlehttp-psr7 <no-dsa> (Minor issue)
https://github.com/guzzle/psr7/security/advisories/GHSA-q7rv-6hp3-vh96

Search for package or bug name: Reporting problems