CVE-2022-24785

NameCVE-2022-24785
DescriptionMoment.js is a JavaScript date library for parsing, validating, manipulating, and formatting dates. A path traversal vulnerability impacts npm (server) users of Moment.js between versions 1.0.1 and 2.29.1, especially if a user-provided locale string is directly used to switch moment locale. This problem is patched in 2.29.2, and the patch can be applied to all affected versions. As a workaround, sanitize the user-provided locale name before passing it to Moment.js.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1009327

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-moment (PTS)buster2.24.0+ds-1vulnerable
bullseye2.29.1+ds-2+deb11u2fixed
bookworm, sid2.29.4+ds-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-momentsourcestretch(unfixed)end-of-life
node-momentsourcebullseye2.29.1+ds-2+deb11u1
node-momentsource(unstable)2.29.2+ds-11009327

Notes

[buster] - node-moment <no-dsa> (Minor issue)
[stretch] - node-moment <end-of-life> (Nodejs in stretch not covered by security support)
https://github.com/moment/moment/security/advisories/GHSA-8hfj-j24r-96c4
https://github.com/moment/moment/commit/4211bfc8f15746be4019bba557e29a7ba83d54c5 (2.29.2)

Search for package or bug name: Reporting problems