CVE-2022-24805

NameCVE-2022-24805
Descriptionnet-snmp provides various tools relating to the Simple Network Management Protocol. Prior to version 5.9.2, a buffer overflow in the handling of the `INDEX` of `NET-SNMP-VACM-MIB` can cause an out-of-bounds memory access. A user with read-only credentials can exploit the issue. Version 5.9.2 contains a patch. Users should use strong SNMPv3 credentials and avoid sharing the credentials. Those who must use SNMPv1 or SNMPv2c should use a complex community string and enhance the protection by restricting access to a given IP address range.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3088-1, DSA-5209-1
Debian Bugs1016139

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
net-snmp (PTS)buster5.7.3+dfsg-5+deb10u2vulnerable
buster (security)5.7.3+dfsg-5+deb10u4fixed
bullseye (security), bullseye5.9+dfsg-4+deb11u1fixed
bookworm5.9.3+dfsg-2fixed
sid, trixie5.9.4+dfsg-1.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
net-snmpsourcebuster5.7.3+dfsg-5+deb10u3DLA-3088-1
net-snmpsourcebullseye5.9+dfsg-4+deb11u1DSA-5209-1
net-snmpsource(unstable)5.9.3+dfsg-11016139

Notes

https://fossies.org/linux/net-snmp/CHANGES (fixed in 5.9.3)
https://github.com/net-snmp/net-snmp/commit/67ebb43e9038b2dae6e74ae8838b36fcc10fc937 (v5.9.2.pre1)
https://github.com/net-snmp/net-snmp/commit/9a0cd7c00947d5e1c6ceb54558d454f87c3b8341 (v5.9.2.pre1)

Search for package or bug name: Reporting problems