CVE-2022-24823

NameCVE-2022-24823
DescriptionNetty is an open-source, asynchronous event-driven network application framework. The package `io.netty:netty-codec-http` prior to version 4.1.77.Final contains an insufficient fix for CVE-2021-21290. When Netty's multipart decoders are used local information disclosure can occur via the local system temporary directory if temporary storing uploads on the disk is enabled. This only impacts applications running on Java version 6 and lower. Additionally, this vulnerability impacts code running on Unix-like systems, and very old versions of Mac OSX and Windows as they all share the system temporary directory between all users. Version 4.1.77.Final contains a patch for this vulnerability. As a workaround, specify one's own `java.io.tmpdir` when starting the JVM or use DefaultHttpDataFactory.setBaseDir(...) to set the directory to something that is only readable by the current user.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs1010693

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
netty (PTS)stretch1:4.1.7-2+deb9u1vulnerable
stretch (security)1:4.1.7-2+deb9u3vulnerable
buster, buster (security)1:4.1.33-1+deb10u2vulnerable
bookworm, sid, bullseye1:4.1.48-4vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nettysource(unstable)(unfixed)unimportant1010693

Notes

https://github.com/netty/netty/security/advisories/GHSA-269q-hmxg-m83q
https://github.com/netty/netty/commit/185f8b2756a36aaa4f973f1a2a025e7d981823f1
Issue exists because of isufficient fix for CVE-2021-21290
Impacts only applications running on Java version 6 and lower.

Search for package or bug name: Reporting problems