CVE-2022-24836

NameCVE-2022-24836
DescriptionNokogiri is an open source XML and HTML library for Ruby. Nokogiri `< v1.13.4` contains an inefficient regular expression that is susceptible to excessive backtracking when attempting to detect encoding in HTML documents. Users are advised to upgrade to Nokogiri `>= 1.13.4`. There are no known workarounds for this issue.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3003-1
Debian Bugs1009787

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby-nokogiri (PTS)buster1.10.0+dfsg1-2vulnerable
bullseye1.11.1+dfsg-2vulnerable
bookworm, sid1.13.7+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ruby-nokogirisourcestretch1.6.8.1-1+deb9u2DLA-3003-1
ruby-nokogirisource(unstable)1.13.5+dfsg-11009787

Notes

https://github.com/sparklemotion/nokogiri/security/advisories/GHSA-crjr-9rc5-ghw8
https://github.com/sparklemotion/nokogiri/commit/e444525ef1634b675cd1cf52d39f4320ef0aecfd

Search for package or bug name: Reporting problems