CVE-2022-24959

NameCVE-2022-24959
DescriptionAn issue was discovered in the Linux kernel before 5.16.5. There is a memory leak in yam_siocdevprivate in drivers/net/hamradio/yam.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2941-1, DSA-5092-1, DSA-5096-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)stretch4.9.228-1fixed
stretch (security)4.9.303-1fixed
buster4.19.235-1fixed
buster (security)4.19.232-1fixed
bullseye5.10.106-1fixed
bullseye (security)5.10.113-1fixed
bookworm5.17.3-1fixed
sid5.17.6-1fixed
linux-4.19 (PTS)stretch (security)4.19.232-1~deb9u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsourcestretch(not affected)
linuxsourcebuster4.19.232-1DSA-5096-1
linuxsourcebullseye5.10.92-2DSA-5092-1
linuxsource(unstable)5.16.7-1
linux-4.19sourcestretch4.19.232-1~deb9u1DLA-2941-1

Notes

[stretch] - linux <not-affected> (Vulnerable code introduced later)
https://git.kernel.org/linus/29eb31542787e1019208a2e1047bb7c76c069536 (5.17-rc2)

Search for package or bug name: Reporting problems