CVE-2022-24963

NameCVE-2022-24963
DescriptionInteger Overflow or Wraparound vulnerability in apr_encode functions of Apache Portable Runtime (APR) allows an attacker to write beyond bounds of a buffer. This issue affects Apache Portable Runtime (APR) version 1.7.0.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-5370-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
apr (PTS)buster1.6.5-1fixed
bullseye (security), bullseye1.7.0-6+deb11u2fixed
bookworm1.7.2-3fixed
sid, trixie1.7.2-3.2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
aprsourcebuster(not affected)
aprsourcebullseye1.7.0-6+deb11u2DSA-5370-1
aprsource(unstable)1.7.2-1

Notes

[buster] - apr <not-affected> (Vulnerable code introduced later)
https://lists.apache.org/thread/fw9p6sdncwsjkstwc066vz57xqzfksq9
http://svn.apache.org/r1904675

Search for package or bug name: Reporting problems