CVE-2022-24999

NameCVE-2022-24999
Descriptionqs before 6.10.3, as used in Express before 4.17.3 and other products, allows attackers to cause a Node process hang for an Express application because an __ proto__ key can be used. In many typical Express use cases, an unauthenticated remote attacker can place the attack payload in the query string of the URL that is used to visit the application, such as a[__proto__]=b&a[__proto__]&a[length]=100000000. The fix was backported to qs 6.9.7, 6.8.3, 6.7.3, 6.6.1, 6.5.3, 6.4.1, 6.3.3, and 6.2.4 (and therefore Express 4.17.3, which has "deps: qs@6.9.7" in its release description, is not vulnerable).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-qs (PTS)buster6.5.2-1vulnerable
bullseye6.9.4+ds-1+deb11u1fixed
bookworm, sid6.11.0+ds+~6.9.7-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-qssourcebullseye6.9.4+ds-1+deb11u1
node-qssource(unstable)6.10.3+ds+~6.9.7-1

Notes

[buster] - node-qs <no-dsa> (Minor issue)
https://github.com/ljharb/qs/pull/428
https://github.com/n8tz/CVE-2022-24999

Search for package or bug name: Reporting problems