CVE-2022-2509

NameCVE-2022-2509
DescriptionA vulnerability found in gnutls. This security flaw happens because of a double free error occurs during verification of pkcs7 signatures in gnutls_pkcs7_verify function.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3070-1, DSA-5203-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gnutls28 (PTS)buster3.6.7-4+deb10u8vulnerable
buster (security)3.6.7-4+deb10u9fixed
bullseye (security), bullseye3.7.1-5+deb11u2fixed
bookworm, sid3.7.8-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gnutls28sourcebuster3.6.7-4+deb10u9DLA-3070-1
gnutls28sourcebullseye3.7.1-5+deb11u2DSA-5203-1
gnutls28source(unstable)3.7.7-1

Notes

https://gnutls.org/security-new.html#GNUTLS-SA-2022-07-07
https://gitlab.com/gnutls/gnutls/-/issues/1383 (restricted)
https://gitlab.com/gnutls/gnutls/-/commit/ce37f9eb265dbe9b6d597f5767449e8ee95848e2

Search for package or bug name: Reporting problems