CVE-2022-2514

NameCVE-2022-2514
DescriptionThe time and filter parameters in Fava prior to v1.22 are vulnerable to reflected XSS due to the lack of escaping of error messages which contained the parameters in verbatim.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1016971

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
fava (PTS)buster1.9-4vulnerable
bullseye1.18-1vulnerable
bookworm, sid1.20.1-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
favasource(unstable)(unfixed)1016971

Notes

https://huntr.dev/bounties/dbf77139-4384-4dc5-9994-45a5e0747429
https://github.com/beancount/fava/commit/ca9e3882c7b5fbf5273ba52340b9fea6a99f3711 (v1.22)

Search for package or bug name: Reporting problems