CVE-2022-25147

NameCVE-2022-25147
DescriptionInteger Overflow or Wraparound vulnerability in apr_base64 functions of Apache Portable Runtime Utility (APR-util) allows an attacker to write beyond bounds of a buffer. This issue affects Apache Portable Runtime Utility (APR-util) 1.6.1 and prior versions.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3332-1, DSA-5364-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
apr-util (PTS)buster1.6.1-4vulnerable
buster (security)1.6.1-4+deb10u1fixed
bullseye (security), bullseye1.6.1-5+deb11u1fixed
trixie, bookworm1.6.3-1fixed
sid1.6.3-1.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
apr-utilsourcebuster1.6.1-4+deb10u1DLA-3332-1
apr-utilsourcebullseye1.6.1-5+deb11u1DSA-5364-1
apr-utilsource(unstable)1.6.3-1

Notes

https://lists.apache.org/thread/np5gjqlohc4f62lr09vrn61vl44cylh8
http://svn.apache.org/r1904728

Search for package or bug name: Reporting problems