CVE-2022-25235

NameCVE-2022-25235
Descriptionxmltok_impl.c in Expat (aka libexpat) before 2.4.5 lacks certain validation of encoding, such as checks for whether a UTF-8 character is valid in a certain context.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2935-1, DSA-5085-1
Debian Bugs1005894

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
expat (PTS)stretch2.2.0-2+deb9u3vulnerable
stretch (security)2.2.0-2+deb9u5fixed
buster, buster (security)2.2.6-2+deb10u4fixed
bullseye (security), bullseye2.2.10-2+deb11u3fixed
bookworm, sid2.4.8-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
expatsourcestretch2.2.0-2+deb9u5DLA-2935-1
expatsourcebuster2.2.6-2+deb10u3DSA-5085-1
expatsourcebullseye2.2.10-2+deb11u2DSA-5085-1
expatsource(unstable)2.4.5-11005894

Notes

https://github.com/libexpat/libexpat/pull/562
https://github.com/libexpat/libexpat/commit/ee2a5b50e7d1940ba8745715b62ceb9efd3a96da
https://github.com/libexpat/libexpat/commit/3f0a0cb644438d4d8e3294cd0b1245d0edb0c6c6
https://github.com/libexpat/libexpat/commit/c85a3025e7a1be086dc34e7559fbc543914d047f
https://github.com/libexpat/libexpat/commit/6a5510bc6b7efe743356296724e0b38300f05379

Search for package or bug name: Reporting problems