CVE-2022-25265

NameCVE-2022-25265
DescriptionIn the Linux kernel through 5.16.10, certain binary files may have the exec-all attribute if they were built in approximately 2003 (e.g., with GCC 3.2.2 and Linux kernel 2.4.20). This can cause execution of bytes located in supposedly non-executable regions of a file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)stretch4.9.228-1vulnerable
stretch (security)4.9.303-1vulnerable
buster4.19.235-1vulnerable
buster (security)4.19.232-1vulnerable
bullseye5.10.106-1vulnerable
bullseye (security)5.10.113-1vulnerable
bookworm5.17.3-1vulnerable
sid5.17.6-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)(unfixed)unimportant

Notes

https://github.com/x0reaxeax/exec-prot-bypass
Not considered a security flaw. If desired because no need for backward compatibility
can be mitigated through a LSM.

Search for package or bug name: Reporting problems