CVE-2022-25304

NameCVE-2022-25304
DescriptionAll versions of package opcua; all versions of package asyncua are vulnerable to Denial of Service (DoS) due to a missing limitation on the number of received chunks - per single session or in total for all concurrent sessions. An attacker can exploit this vulnerability by sending an unlimited number of huge chunks (e.g. 2GB each) without sending the Final closing chunk.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python-opcua (PTS)buster0.98.6-2vulnerable
bullseye0.98.11-1vulnerable
bookworm, sid0.98.11-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python-opcuasource(unstable)(unfixed)

Notes

[bullseye] - python-opcua <no-dsa> (Minor issue)
[buster] - python-opcua <no-dsa> (Minor issue)
https://github.com/FreeOpcUa/python-opcua/issues/1466
https://security.snyk.io/vuln/SNYK-PYTHON-OPCUA-2988730

Search for package or bug name: Reporting problems