CVE-2022-25314

NameCVE-2022-25314
DescriptionIn Expat (aka libexpat) before 2.4.5, there is an integer overflow in copyString.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-5085-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
expat (PTS)stretch2.2.0-2+deb9u3fixed
stretch (security)2.2.0-2+deb9u5fixed
buster, buster (security)2.2.6-2+deb10u4fixed
bullseye (security), bullseye2.2.10-2+deb11u3fixed
bookworm, sid2.4.8-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
expatsourcestretch(not affected)
expatsourcebuster2.2.6-2+deb10u3DSA-5085-1
expatsourcebullseye2.2.10-2+deb11u2DSA-5085-1
expatsource(unstable)2.4.5-1

Notes

[stretch] - expat <not-affected> (Vulnerable code introduced later)
https://github.com/libexpat/libexpat/pull/560
https://github.com/libexpat/libexpat/commit/efcb347440ade24b9f1054671e6bd05e60b4cafd

Search for package or bug name: Reporting problems