CVE-2022-25326

NameCVE-2022-25326
Descriptionfscrypt through v0.3.2 creates a world-writable directory by default when setting up a filesystem, allowing unprivileged users to exhaust filesystem space. We recommend upgrading to fscrypt 0.3.3 or above and adjusting the permissions on existing fscrypt metadata directories where applicable.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1006485

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
fscrypt (PTS)buster0.2.4-2vulnerable
buster (security)0.2.4-2+deb10u1vulnerable
bullseye0.2.9-1vulnerable
bookworm0.3.3-1fixed
trixie, sid0.3.4-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
fscryptsource(unstable)0.3.3-11006485

Notes

[bullseye] - fscrypt <no-dsa> (Minor issue)
[buster] - fscrypt <no-dsa> (Minor issue)
https://www.openwall.com/lists/oss-security/2022/02/24/1
https://github.com/google/fscrypt/commit/6e355131670ad014e45f879475ddf800f0080d41

Search for package or bug name: Reporting problems