CVE-2022-25328

NameCVE-2022-25328
DescriptionThe bash_completion script for fscrypt allows injection of commands via crafted mountpoint paths, allowing privilege escalation under a specific set of circumstances. A local user who has control over mountpoint paths could potentially escalate their privileges if they create a malicious mountpoint path and if the system administrator happens to be using the fscrypt bash completion script to complete mountpoint paths. We recommend upgrading to version 0.3.3 or above
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1006485

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
fscrypt (PTS)buster0.2.4-2vulnerable
buster (security)0.2.4-2+deb10u1vulnerable
bullseye0.2.9-1vulnerable
bookworm0.3.3-1fixed
trixie, sid0.3.4-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
fscryptsource(unstable)0.3.3-11006485

Notes

[bullseye] - fscrypt <no-dsa> (Minor issue)
[buster] - fscrypt <no-dsa> (Minor issue)
https://www.openwall.com/lists/oss-security/2022/02/24/1
https://github.com/google/fscrypt/commit/fa1a1fdbdea65829ce24a6b6f86ce2961e465b02

Search for package or bug name: Reporting problems