CVE-2022-25647

NameCVE-2022-25647
DescriptionThe package com.google.code.gson:gson before 2.8.9 are vulnerable to Deserialization of Untrusted Data via the writeReplace() method in internal classes, which may lead to DoS attacks.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3001-1, DLA-3100-1, DSA-5227-1
Debian Bugs1010670

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libgoogle-gson-java (PTS)buster2.8.5-3vulnerable
buster (security)2.8.5-3+deb10u1fixed
bullseye2.8.6-1vulnerable
bullseye (security)2.8.6-1+deb11u1fixed
bookworm, sid2.9.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libgoogle-gson-javasourcestretch2.4-1+deb9u1DLA-3001-1
libgoogle-gson-javasourcebuster2.8.5-3+deb10u1DLA-3100-1
libgoogle-gson-javasourcebullseye2.8.6-1+deb11u1DSA-5227-1
libgoogle-gson-javasource(unstable)2.9.0-11010670

Notes

https://github.com/google/gson/pull/1991
https://github.com/google/gson/commit/e6fae590cf2a758c47cd5a17f9bf3780ce62c986 (gson-parent-2.8.9)
https://snyk.io/vuln/SNYK-JAVA-COMGOOGLECODEGSON-1730327

Search for package or bug name: Reporting problems