CVE-2022-25844

NameCVE-2022-25844
DescriptionThe package angular after 1.7.0 are vulnerable to Regular Expression Denial of Service (ReDoS) by providing a custom locale rule that makes it possible to assign the parameter in posPre: ' '.repeat() of NUMBER_FORMATS.PATTERNS[1].posPre with a very high value. **Note:** 1) This package has been deprecated and is no longer maintained. 2) The vulnerable versions are 1.7.0 and higher.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1014779

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
angular.js (PTS)buster1.5.10-1vulnerable
bookworm, sid, bullseye1.8.2-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
angular.jssource(unstable)(unfixed)1014779

Notes

[bullseye] - angular.js <no-dsa> (Minor issue)
[buster] - angular.js <no-dsa> (Minor issue, probably even not-affected)
[stretch] - angular.js <ignored> (Nodejs in stretch not covered by security support)
https://snyk.io/vuln/SNYK-JS-ANGULAR-2772735

Search for package or bug name: Reporting problems