CVE-2022-2585

NameCVE-2022-2585
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3102-1, DSA-5207-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)buster4.19.249-2fixed
buster (security)4.19.260-1fixed
bullseye5.10.140-1fixed
bullseye (security)5.10.136-1fixed
bookworm, sid5.19.11-1fixed
linux-5.10 (PTS)buster (security)5.10.136-1~deb10u3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsourcebuster(not affected)
linuxsourcebullseye5.10.136-1DSA-5207-1
linuxsource(unstable)5.18.16-1
linux-5.10sourcebuster5.10.136-1~deb10u1DLA-3102-1

Notes

[buster] - linux <not-affected> (Vulnerable code introduced later)
https://lore.kernel.org/lkml/20220809170751.164716-1-cascardo@canonical.com/T/#u
https://www.openwall.com/lists/oss-security/2022/08/09/7

Search for package or bug name: Reporting problems