CVE-2022-2589

NameCVE-2022-2589
DescriptionCross-site Scripting (XSS) - Reflected in GitHub repository beancount/fava prior to 1.22.3.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1016971

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
fava (PTS)buster1.9-4vulnerable
bullseye1.18-1vulnerable
bookworm, sid1.20.1-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
favasource(unstable)(unfixed)1016971

Notes

[bullseye] - fava <no-dsa> (Minor issue)
[buster] - fava <no-dsa> (Minor issue)
https://huntr.dev/bounties/8705800d-cf2f-433d-9c3e-dbef6a3f7e08/
https://github.com/beancount/fava/commit/68bbb6e39319deb35ab9f18d0b6aa9fa70472539 (v1.22.3)

Search for package or bug name: Reporting problems